Stacks compatibility matrix

Below is a matrix that shows the compatibility between the different versions of Engine Yard Cloud Stack, and which versions of Ruby, Rails, and Database engines can be ran on every version of the Stacks.

  EYC v7 EYC v6 EYC v5 (*) EYC v4 (*) EYC v2 (*) EYC v1 (*)
Release date July '22 July '19 October '16 November '12 July '09 March '09
EC2 Generation 5,6 4,5 4,5 3,4 1,2,3 1, 2
Core Linux Distro Ubuntu 20.04 Ubuntu 18.04 EY Gentoo 16 EY Gentoo 12 EY Gentoo 09 EY Gentoo 09
Ruby

2.[5|6|7]

3.[0|1|2]

2.[5|6|7]

3.[0|1]

2.[2|3|4|5|6]

1.[8|9]

2.[0|1|2|3|4]

1.8 1.8
Rails 5, 6, 7 5, 6, 7 4, 5 3, 4, 5 3 3
PHP WIP 7.3, 7.5 5.4, 5.5 5.3 Not Supported Not Supported
Node JS WIP up to 16 up to 12 up to 8 Not Supported Not Supported
PostgreSQL (**)

9.[5|6]

1[0|1|2|3|4]

9.[5|6]

1[0|1]

9.[4|5|6]

10

9.[2|3|4] 9.[1|2|3] 9.[1|2|3]
MySQL (**)

5.7

8.0

5.[5|6|7]

8.0

5.[5|6|7] 5.[5|6] 5.[0|1|5|6] 5.[0|1|5|6]
Custom Recipes LINK LINK LINK LINK N/A N/A

 

(*) End of Life Stack, only consulting or PS Support is offered. We strongly recommend migrating to a supported EYC stack.

(**) Versions available for running on EC2 instances.  RDS is available based on AWS's timeline for MySQL and PostgreSQL.

Notes:

On EYC v7, versions of PostgreSQL above 11 can be set using the environment variable 'EY_POSTGRES_VERSION' to the full version (i.e. "12.05").

On EYC v7, as well, versions of Ruby above 3.0.0 can be set using the environment variable 'EY_RUBY_VERSION' to the full version (i.e. "3.2.2").

 

 

Comments

Article is closed for comments.